Back to overview
Downtime

Major outage affecting PollPe services

Mar 2, 2026 at 2:21am UTC
Affected services
pollpe.com
app.pollpe.com
poll.pe
api.pollpe.com
core.pollpe.com
dailypoll-api.pollpe.com
taskpe-api.pollpe.com
aos.pollpe.com

Resolved
Mar 3, 2026 at 1:08pm UTC

All services have been fully restored.
The issue has been resolved and systems are operating normally.

We appreciate your patience and understanding while we worked through this. Thank you for your continued trust in PollPe.

Created
Mar 2, 2026 at 2:21am UTC

We’re investigating a platform-wide outage impacting Survey Builder, APIs, and the Rewards App. We are working with our cloud provider to restore access.